Log In
Home
Support
Demos
Documentation
Blogs
Training
Webinars
[Expand]General Information
[Expand]WinForms Controls
[Expand]ASP.NET Controls and MVC Extensions
[Expand]ASP.NET Bootstrap Controls
[Expand]ASP.NET Core Bootstrap Controls
[Expand]WPF Controls
[Expand]Xamarin Controls
[Expand]Windows 10 App Controls
[Expand]Document Server
[Expand]Reporting
[Expand]Report Server
[Expand]Dashboard
[Expand]eXpressApp Framework
[Expand]CodeRush
[Collapse]CodeRush Classic
  What's New
 [Collapse]System Requirements
   System Requirements (CodeRush)
   Visual Studio Support History
 [Expand]Concepts
 [Expand]Visual Elements
 [Expand]Tool Windows
 [Expand]CodeRush Options
 [Expand]Examples
  Get More Help
[Expand]Cross-Platform Core Libraries
[Expand]Tools and Utilities
 End-User Documentation

System Requirements (CodeRush)

This document describes the system requirements for installing and using CodeRush on a development machine. If you are working with an older version of the IDE that is not supported by the current version of CodeRush, please refer to the Visual Studio Support History topic to choose the most appropriate CodeRush version.

You can use CodeRush with any of the following IDEs:

  • Microsoft Visual Studio 2010;
  • Microsoft Visual Studio 2012;
  • Microsoft Visual Studio 2013;
  • Microsoft Visual Studio 2015.

How would you rate this topic?​​​​​​​